Announcement

Collapse
No announcement yet.

Old Timers?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Nechronius
    replied
    Originally posted by dmark101 View Post
    what the heck was that bracket for anyway? i must be old because i can't remember what that was.

    on another note, i fired up my pgt the other day, had it on facebook live, gave you a shout out when i showed off my PRD RSTB. should have mentioned the STS i have as well.
    It was a PRD bracket that held a nitrous engagement switch for a very short lived Nitrous experiment.

    Took another step forward in getting the car road worthy.

    https://youtu.be/wQabOOmVWBc

    I'll be faced with a bit of a chicken/egg dilemma real soon. Car needs tires if it's going to be road worthy. But to be road worthy it needs to pass emissions. But if can't pass emissions then why get new tires. Passing emissions will possibly require removal/replacement of the Hotshot headers with the stock logs, which I'm ok with if I have to, but would rather not. Those headers were a big part of why I just let the Probe die in the first place, biggest mistake ever...

    Leave a comment:


  • dmark101
    replied
    what the heck was that bracket for anyway? i must be old because i can't remember what that was.

    on another note, i fired up my pgt the other day, had it on facebook live, gave you a shout out when i showed off my PRD RSTB. should have mentioned the STS i have as well.

    Leave a comment:


  • Probesport
    replied
    Very old school.

    Leave a comment:


  • Nechronius
    replied
    Thanks, Ken!

    You'll appreciate this. I realized as I was working on the car that I was still representin'. Pictures look familiar?

    http://i.imgur.com/0LGfT94.jpg

    http://i.imgur.com/fedq9p5.jpg

    Leave a comment:


  • Probesport
    replied
    Jin! Long time no see. Welcome back home

    Leave a comment:


  • Nechronius
    replied
    Well I finally did it. I got my car started.

    https://youtu.be/yj4c2JxXflk

    Quick background:
    Car sat since June of 2007. A lot of the usual problems. Hard starting being the biggest one. Got a new job and then a new car in Sep/Oct 2006 and I just didn't have Time to deal with the Probe's issues anymore.

    Over two years ago I gave it a half hearted attempt to crank it with no success, it wouldn't budge. I almost gave up. Late last year I finally decided that if I didn't get it running again by April 2017 (Basically before Fabulous Fords show at Knott's) I'd part it out.

    I have a bit more cleanup to do and testing for road worthiness, but by this weekend I'll give the car a quick drive in my neighborhood, to make sure it works. I only moved it about five feet back and forth to get better positioning in the garage.

    I guess I'll be back to active duty Probing pretty soon.

    Leave a comment:


  • Jim
    replied
    Don't know why, but had an impulse to go check the ol' Probetalk forums today after several years.

    I guess this is the thread to be posting in!

    Lots of good memories...

    Leave a comment:


  • StreetThisMX6
    replied
    I met so many good people on PT. I am amazed this forum is still alive and kicking after all these years.


    Originally posted by 93GTSR View Post
    For some reason i felt the urge to check back in today, after not being on the board in nearly 8 years or so. Hope everyone is doing well! I now make my living building/modifying another 90's sports car (the MKII MR2). Been doing it for about 9 years now or so, and doing well!

    -Ty

    Glad to see you are living out your passion!

    Leave a comment:


  • 93GTSR
    replied
    For some reason i felt the urge to check back in today, after not being on the board in nearly 8 years or so. Hope everyone is doing well! I now make my living building/modifying another 90's sports car (the MKII MR2). Been doing it for about 9 years now or so, and doing well!

    -Ty

    Leave a comment:


  • KnezicDex
    replied
    Hi, i might be probing again after 3 years

    Leave a comment:


  • Probesport
    replied
    Cotton candy, Sweet and low.

    Leave a comment:


  • spada
    replied
    Leif's wedding was fun. Decent DJ too.

    Leave a comment:


  • pgt4speed
    replied
    Originally posted by FelipeT View Post
    Well, crap, Sandon, I never thought of if that way, but you're right, so have I!

    I'm guessing I'm one of the few original owners still left. And yes, I still have it.

    (I also still have the bicycle and microwave oven I bought back in '95 as well.)
    I was thinking about how you've been. Glad to hear that you still have the Probe as well

    ---------- Post added at 03:34 PM ---------- Previous post was at 03:32 PM ----------

    Originally posted by Probesport View Post
    I haven't seen Leif in some time, last was running into him at lunch a year or so back.

    Julian, Mike - haven't heard from in forever.
    I ran into Leif last summer riding my bike around the neighborhood.

    Leave a comment:


  • Probesport
    replied
    I haven't seen Leif in some time, last was running into him at lunch a year or so back.

    Julian, Mike - haven't heard from in forever.

    Leave a comment:


  • Bryan_Johnson
    replied
    Not quite sure what even prompted me to log in.....but anyway...

    I didn't join until March 2000 but I was previously on the old BH.org mailing list...so if that doesn't make me an old timer, I don't know what will.

    Good to see some folks I haven't talked to in forever I also wonder what became of Julian....and what about Leif (alfie?) and Mike Palmer?

    Not an original owner but bought my 91' in November of 92'. Currently it sits safely in the garage with 329k.

    Interestingly enough my friend just texted me a photo of a 90'LX I bought in '99 and sold in '09. Car still runs and drives good per his cousin who just bought. My total amateur paint job seems to be holding up pretty well too. If anyone remembers the digital dash on the 1st gen it can't physically read out over 199999.9 mies....it rolls back to 100000.0. My friends cousin was super pissed when I told him it really had 216k on it, not 116k as the cluster indicated. I sold it at 180k (original miles), so someone down the line was not-so-honest....

    Leave a comment:

Working...
X

Debug Information