Announcement

Collapse
No announcement yet.

Old Timers?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • rph74
    replied
    Hello everyone, I haven’t posted on here for 17 years lol. Not sure why I got the notion to sign on, but was fun to see my post introducing myself as a 26 year old. I do miss my old MX6 turbo. Since then I’ve owned about 20 different cars. My current toy is a 98 Camaro Z28 6 speed. My sons are just getting old enough to appreciate fun cars.

    I will soon be teaching my oldest how to drive a manual trans. He will be one of a select few of his peers who can do it I’m afraid.
    Last edited by rph74; January 18, 2018, 07:52 PM.

    Leave a comment:


  • waderpgt
    replied
    Hello!

    Bitter sweet coming back here, as the HOA is forcing me to get rid of my probe this week.

    But I had a lot of great memories here as we helped each other figure out things to make our cars run better or save some money on parts!

    I remember all the responses when I posted some of the first pictures of the 1 wire O2 swap back in the day. Good times!

    If anyone can use a running & driving 94 probe check out my post in the For Sale section.

    Leave a comment:


  • boomermsu
    replied
    Hello!!! This is a strange thread of old old people posting.

    Leave a comment:


  • ugasouthernprid
    replied
    Hello folks. Just checking in. Thanks for all the information and help!

    Leave a comment:


  • Domino81
    replied
    Hi, all.

    Leave a comment:


  • dmark101
    replied
    well, i'm still here. barely.

    Leave a comment:


  • Probe 2C
    replied
    I still have an official probetalk.com administrator t-shirt.

    It's a good but tighter than it was back in the day

    Leave a comment:


  • bocajwest05
    replied
    I've spent the last week or so trying to remember my login, Finally got it and still have the probe. It needs a little work, Tires, alternator and battery. Fire it up from time to time and still runs great but who knows what else has gone wrong while it has sat collecting rust over the last couple years. See a first gen GT running around town lately, I want one now

    Leave a comment:


  • Scott
    replied
    Saw someone driving a Probe GT like my old one today on the interstate.
    I actually remember my old login here...
    Not sure which of those two things is the more impressive

    Leave a comment:


  • j-dogg
    replied
    Originally posted by Pat_SOPOC View Post
    This thread has so much win.

    PT is what you use the internet fo'.
    Only if you wanna wait for 10 minutes bro

    Leave a comment:


  • Pat_SOPOC
    replied
    This thread has so much win.

    PT is what you use the internet fo'.

    Leave a comment:


  • spada
    replied
    Can you talk on the mic?

    Leave a comment:


  • Dan [Sac]
    replied
    THB alert

    Leave a comment:


  • TheProbeKid
    replied
    Is this thing on?

    Leave a comment:


  • FelipeT
    replied
    Originally posted by Nechronius View Post
    Still rocking the Borla. Sounds great. Finally did all of the vacuum hoses with silicone and got the old dog back on the road again. Runs a LOT better now, and only one CEL left to figure out instead of three or four.

    I did a 2nd gear pull for the first Time in ages, we're talking something like 11+ years and 50k+ miles ago. Seriously I hadn't floored it in that long. And my first reaction was, uh, that's it? Huh... Either the car is way out of tune or I'm too used to actually getting acceleration when I floor the Evo. How easily we get spoiled once we get a taste of real power.
    I think that it's more of the second. I commute to work exclusively by motorcycle, so on the few occasions that I drive a car they all seem slow. OK, so the Celica actually is slow, but the Galant VR4 isn't, and I get the same, "huh, is that it?" reaction. Still, love my cars, and some things are too big to carry on the bikes.

    Leave a comment:

Working...
X

Debug Information