Advertise with ProbeTalk - click here to find out how!



Advertise with ProbeTalk - click here to find out how!
Advertise with ProbeTalk - click here to find out how!

ProbeTalk.com Forums

Go Back   ProbeTalk.com Forums > Tech Section > 2nd Gen (93-97) I4 2.0L

2nd Gen (93-97) I4 2.0L Discussion of Maint Issues for I4

Reply
 
Thread Tools
Old August 28th, 2014, 12:03 PM   #1
blackpgt1994
North North American Mod
 
blackpgt1994's Avatar
 
Join Date: Jun 2003
Location: Toronto, Canada
Posts: 8,482
CEL 55, (Pulse Shift Generator)

Fired up my 93 for a drive, looks like I've lost overdrive.

- O/D light flashes on and off as soon as go into second gear.
- All shifts are harder than normal.
- No 4th gear, O/D
- Pulled the codes the from the MECS: code 55 (Pulse Shift Generator)
- Replaced the PSG with a OEM ford unit. Still have the same problem.


Did a search on probetalk and google, and couldn't really find a good answer for else could cause a code 55.
Anyone else run into this before or find a solution?
__________________
-Kyle
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

93 Black probe (K-sporting)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


**

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
**

Last edited by blackpgt1994; August 29th, 2014 at 12:28 PM.
blackpgt1994 is offline   Reply With Quote
Old August 28th, 2014, 04:27 PM   #2
jasons96pgtze
Colt Cams BB Master
 
Join Date: Mar 2008
Location: Kansas
Posts: 3,005
Ive never seen that code on an auto trans for one of our cars before.. How did it drive the last time you drove it and how long ago was that?
__________________
1995 turbocharged pgt with countless mods.. check it out here

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1993 turbocharged pgt daily driver check it out here..

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jasons96pgtze is offline   Reply With Quote
Old August 29th, 2014, 12:29 PM   #3
blackpgt1994
North North American Mod
 
blackpgt1994's Avatar
 
Join Date: Jun 2003
Location: Toronto, Canada
Posts: 8,482
Probably around 2 weeks between the last time I drove it without issue, and the time I fired it up again and it didn't have O/D / started throwing this code.
__________________
-Kyle
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

93 Black probe (K-sporting)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


**

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
**
blackpgt1994 is offline   Reply With Quote
Old August 30th, 2014, 07:54 AM   #4
unionrdr
Donating Member
 
unionrdr's Avatar
 
Join Date: May 2007
Location: Sheffield,Ohio
Age: 61
Posts: 7,820
That's a sign you need a nee VSS-Vehicle Speed Sensor. It also contains a Magnetic Pulse Generator that feeds engine speed info to the computer, other sensors & the like. It's on the back side of the ATX near the bell housing.
__________________



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
'94 PROBE SE Middle-aged croozr
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
unionrdr is offline   Reply With Quote
Old September 2nd, 2014, 06:40 AM   #5
blackpgt1994
North North American Mod
 
blackpgt1994's Avatar
 
Join Date: Jun 2003
Location: Toronto, Canada
Posts: 8,482
Quote:
Originally Posted by unionrdr View Post
That's a sign you need a nee VSS-Vehicle Speed Sensor. It also contains a Magnetic Pulse Generator that feeds engine speed info to the computer, other sensors & the like. It's on the back side of the ATX near the bell housing.

I was looking into it being a VSS failure as well, but wouldn't my speedometer be non-functioning as well if it had failed?
__________________
-Kyle
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

93 Black probe (K-sporting)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


**

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
**
blackpgt1994 is offline   Reply With Quote
Old November 13th, 2017, 08:33 PM   #6
blackpgt1994
North North American Mod
 
blackpgt1994's Avatar
 
Join Date: Jun 2003
Location: Toronto, Canada
Posts: 8,482
Does anyone happen to know the part# or have a photo of the VSS for the 93 2.0L?
__________________
-Kyle
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

93 Black probe (K-sporting)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


**

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
**
blackpgt1994 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pulse generator code 55...... 74eldo 2nd Gen (93-97) V6 2.5L 5 January 8th, 2010 02:17 PM
Speed Pulse generator or TSS and TCM jyi21004 2nd Gen (93-97) V6 2.5L 3 September 29th, 2006 12:22 PM
WTB: VSS and pulse generator Griffon783 Wanted 0 November 18th, 2002 10:12 PM
pulse signal generator crook 2nd Gen (93-97) I4 2.0L 2 July 30th, 2002 02:05 PM
pulse generator 91REDLX 1st Gen (89-92) All 2 April 10th, 2001 08:17 PM


All times are GMT -7. The time now is 12:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ProbeTalk.com is not affiliated in any way with the Ford Motor Company, the Mazda Motor Corporation, or any subsidiaries of either company.
All views and opinions expressed on this message board are those of the author and not the owners of ProbeTalk.com.